$re = '/(?!(?:\[\!.*))\]/m';
$str = '_dynamic_text_[!_dynamic_text_]_dynamic_text_
_dynamic_text__dynamic_text_]_dynamic_text_';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);