import Foundation
let pattern = #"((\+?\d{1,3}[\d{2,}\.\- \(\)]{11,}))|(\+?[\d]{10,})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Вариантов написания телефонов достаточно много.
Телефоны имеют разное количество цифр: 10, 11, 12.
Разное написание:
+7 999 999 99 99
7 999 999 99 99
+7999 999 99 99
7999 999 99 99
+7999-999-99-99
7999-999-99-99
+7999-999-9999
7999-999-9999
+7999-9999999
7999-9999999
+79999999999
79999999999
+7.999.999.99.99
+7(999) 999-99-99
+123 (999) 555-66-29
и вместо цифры страны с оной цифрой 7, есть коды по 2 и по 3 цифры.
Можно придумать и ещё много вариантов написания номера телефона.
Как это всё учесть в выражении?
В тексте могут содержаться ссылки +555 (999) 555-66-29 на фотографии и ссылки на страницы сайта, в которых могут быть цифры. Как не зацепить цифры в ссылках? Как их отсортировать от номеров телефонов?
1_2017092902182426089.jpg
123451_2017092902182426089.png
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"убито "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)