$re = '/(\'\?\')|(\?)/m';
$str = '? \'?\' ? \'barmi?\' ? \'?valami\' ? \'akar?mi\'';
$subst = "$1Q";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;