#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?smi)^\|[^\n]+\|\n?\n"
Local $sString = "|Runtime version|Shipped with |Internal version|" & @CRLF & _
"|---------------|-----------------------------------|----------------| " & @CRLF & _
"|`1.0` |Business Central April 2018 Release|12.0|" & @CRLF & _
"|`2.0` |Business Central Fall '18 Release |13.0|" & @CRLF & _
"|`3.0` |Business Central Spring '19 Release|14.0|" & @CRLF & _
"|`4.0` |Business Central 2019 release wave 2|15.0|" & @CRLF & _
"|`5.0` |Business Central 2020 release wave 1|16.0|" & @CRLF & _
"|`6.0` |Business Central 2020 release wave 2|17.0|" & @CRLF & _
"|`6.1` |Business Central 2020 release wave 2 update 1|17.1|" & @CRLF & _
"|`6.2` |Business Central 2020 release wave 2 update 2|17.2|" & @CRLF & _
"|`6.3` |Business Central 2020 release wave 2 update 3|17.3|" & @CRLF & _
"|`6.4` |Business Central 2020 release wave 2 update 4|17.4|" & @CRLF & _
"|`7.0` |Business Central 2021 release wave 1|18.0|" & @CRLF & _
"|`7.1` |Business Central 2021 release wave 1 update 1|18.1|" & @CRLF & _
"|`7.2` |Business Central 2021 release wave 1 update 2|18.2|" & @CRLF & _
"|`8.0` |Business Central 2021 release wave 2|19.0|" & @CRLF & _
"|`9.0` |Business Central 2022 release wave 1|20.0|" & @CRLF & _
"|`9.1` |Business Central 2022 release wave 1 update 1|20.1|" & @CRLF & _
"|`9.2` |Business Central 2022 release wave 1 update 2|20.2|" & @CRLF & _
"|`10.0` |Business Central 2022 release wave 2|21.0|" & @CRLF & _
"|`11.0` |Business Central 2023 release wave 1|22.0|" & @CRLF & _
"|`12.0` |Business Central 2023 release wave 2|23.0|" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")