import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\\plain(?:(?!\\\\plain).)*\\\\field\\{\\\\\\*\\\\fldinst\\{ HYPERLINK \"(.*?)\" \\}\\}\\{\\\\fldrslt\\{(.*?)\\}\\}\\}\\}\\\\plain.*? ";
final String string = "\\plain\\f2 This is the first part of the note. This is the second part of the note. This is the \\plain\\f2\\fs24\\cf6{\\txfielddef{\\*\\txfieldstart\\txfieldtype1\\txfieldflags144\\txfielddataval44334\\txfielddata 35003800380039000000}{\\*\\txfielddatadef\\txfielddatatype1\\txfielddata 340034003300330034000000}{\\*\\txfieldtext 20{\\*\\txfieldend}}{\\field{\\*\\fldinst{ HYPERLINK \"44334\" }}{\\fldrslt{20}}}}\\plain\\f2\\fs24 part of the note.\n\n"
+ "\\plain\\f2 This is the first part of the note. This is the second part of the note. This is the \\plain\\f2\\fs24\\cf6{\\txfielddef{\\*\\txfieldstart\\txfieldtype1\\txfieldflags144\\txfielddataval44334\\txfielddata 35003800380039000000}{\\*\\txfielddatadef\\txfielddatatype1\\txfielddata 340034003300330034000000}{\\*\\txfieldtext 20{\\*\\txfieldend}}{\\field{\\*\\fldinst{ HYPERLINK \"44334\" }}{\\fldrslt{20}}}}\\plain\\f2\\fs24";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}