const regex = /^(www.|http[s]?\:\/\/|[\w\-_]+\.\w+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(www.|http[s]?\\:\\\/\\\/|[\\w\\-_]+\\.\\w+)', 'gm')
const str = `https://mohsensoft.com/aff/
www.mohsensoft.com/aff/
mohsensoft.com/aff/
https://www.mohsensoft.com/aff/
https://mohsen.com/aff/
product/daraee
blog.mohsensoft.com/ttt
blog.dsfsf.com
ds-fsf.com/edrger
fg7j.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}