$re = '/([0])([23478]\d{8})/m';
$str = '0399999999
0400000000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);