$re = '/^([A-Za-z]{3}|[A-Za-z][0-9]|[0-9][A-Za-z])([0-9]+)$/m';
$str = 'X3567
-> X3 and 567
5U9997
-> 5U and 9997';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);