package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)-?\d+\.?\d+`)
var str = `DELZZ 3301.23
KUTY 4.32 SERI -0.023`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}