re = /^[\w!#$%&'*+\-\=?\^_`{|}~]+(\.[\w!#$%&'*+\-\?\^_`{|}~]+)*@((([\-\w]+\.)+[a-zA-Z]{2,4})|(([0-9]{1,3}\.){3}[0-9]{1,3}))$/m
str = 'antonio.pz@outlook.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end