# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\d{2}\w-\d{5}_(?P<code>DC\d{1,3})_(?P<well_adress>\w\d{2})_(?P<id>\d*)_(?P<plate>P[1-3])_(?P<wdh>W_)*UV-metric (?P<solvent>psKa|pKa).t3r"
test_str = ("20F-22003_DC8_D03_1032246_P1_UV-metric psKa.t3r\n"
"20F-29001_DC8_D03_1032246_P1_W_UV-metric psKa.t3r\n"
"20F-26012_DC29_F21_1088043_P1_UV-metric psKa.t3r\n"
"20G-03010_DC60_L03_1366347_P1_UV-metric pKa.t3r\n"
"20G-04001_DC28_F19_1087258_P1_W_UV-metric psKa.t3r\n"
"21I-27003_DC245_D13_7018930044_P1_UV-metric psKa.t3r\n"
"20H-26004_DC124_J03_1216895_P2_UV-metric pKa.t3r\n"
"20I-03024_DC168_L12_105750012_P2_UV-metric psKa.t3r\n"
"20J-05001_DC132_K06_1298433_P2_W_UV-metric psKa.t3r\n"
"21I-14006_DC218_F07_1056516_P3_UV-metric psKa.t3r\n"
"test.txt")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.