package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d+-\d+-\d+)`)
var str = `123-456-789-111-222
6548-24-365-111-222`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}