re = /^((?! Com) (?:(?! Com).)+)?( Com:.*)?$/m
str = ' Com: 123
abc Com: 123
abc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end