$re = '/\b(?<![{}])(\w+)\{([^{}]*)\}/m';
$str = '# It should ignore the anotherone{test{nest}}
new{test}anotherone{test{nest}}new{test}new{test}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);