$re = '/\b(pl|play|player)\b/mi';
$str = '
pl
play
player';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);