re = /^Python/m
str = 'Python language
python algorithm
code Python
Python script'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end