package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d*[a-zA-Z]{1,}\d*`)
var str = `2342**+5665..34`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}