re = /(?<!,)Fri(?:day)?:/m
str = 'Sunday:Monday:Tuesday:Wednesday:Thursday:Friday:Saturday:Sun:Mon:Tue:Wed:,Thu:,Fri:,Sat:'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end