use strict;
my $str = '<div class="contact-phone-icon sprite_view_icn_CnPhone"></div>
<div id="number-third-digit-space" style="display:none">
<div class="contact-phone-prefix">017</div>
<div class="contact-phone-number">3816648</div>
</div>
<div id="number-second-digit-space" style="display:none">
<div class="contact-phone-prefix">01</div>
<div class="contact-phone-number">73816648</div>
</div>';
my $regex = qr@[^<]*<div[^>]*id="number-third-digit-space"[^<]*<div[^>]*class="[^"]*(?<="|\s)contact-phone-prefix(?="|\s[^>]*)">(?<mobile>\d+).*?(\d+)@imsp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}