$re = '/(?<!\S)(?!\d+(?!\S))\w+(?:-\w+)*(?!\S)/m';
$str = 'Rood Li-Ion 12 G6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);