re = /(?<schema>[a-z]+):\/\/(?<domain>[^:\/]+)(?<port>:[0-9]+)\/(?<theFirstPart>[\w]+)\/.*/m
str = 'http://192.168.15.122:3000/adjusterAnalytics/individual/Xh7HTIgGw1RqnsK2TuJtiUIMahy2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end