const regex = /^(?=.*[A-Za-z])(?=.*\d)(?=.*[!#$%\-_=+<>])[A-Za-z\d!#$%\-_=+<>]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*[A-Za-z])(?=.*\\d)(?=.*[!#$%\\-_=+<>])[A-Za-z\\d!#$%\\-_=+<>]+$', 'gm')
const str = `jkj2#ff43#\$#
jkj2#f f43#\$#`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}