$re = '~(?<=(?<!/)/)(?!/)[^?\n]+~m';
$str = 'https://example.com/link
https://example.com/link?code=1234
https://example.com/link/with/longer/path';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);