use strict;
my $str = 'openEHR-EHR-EVALUATION.diagnosis.v1
openEHR-EHR-COMPOSITION.report.v1
openEHR-EHR-COMPOSITION.report-procedure.v1
openEHR-EHR-COMPOSITION.care_plan.v0
openEHR-DEMOGRAPHIC-PERSON.person.v1
openEHR-EHR-OBSERVATION.test.v0
openEHR-EHR-OBSERVATION.test.v0.0.20
openEHR-EHR-OBSERVATION.test-extended.v1.0.20
openEHR-EHR-OBSERVATION.test-extended.v1.0.20-rc.1
openEHR-EHR-OBSERVATION.test-extended.v1.0.20-rc
openEHR-EHR-OBSERVATION.second_test.v1.3.5-rc.3
openEHR-EHR-OBSERVATION.second_test-extended.v1.3.5-alpha
openEHR-EHR-OBSERVATION.second_test-extended.v1.0.20
ISO-ISO13606-ENTRY.test.v0.1.9
br.ms::openEHR-EHR-OBSERVATION.haematology_result.v1.0.0
br.ms::openEHR-EHR-OBSERVATION.haematology_result.v1.2.15-alpha.45
br.ms::openEHR-EHR-OBSERVATION.haematology_result.v3.22.125-rc.7
org.openehr::openEHR-EHR-OBSERVATION.haematology.v1.2.0
uk.org.primary_care::openEHR-EHR-OBSERVATION.haematology_result.v1.2.15
at0003
at0003.190
at0000
at0.1
at0.123
at0.12345
at1234
at0000
id1.1
id1.77
========================
openEHR-EHR-OBSERVATION.test-extended.v1.20-rc.1
openEHR-EHR-OBSERVATION.test-extended.v1.20-rc
ISO-ISO-13606-ENTRY.test.v0.1.9
openEHR-EHR-OBSERVATION.v0.2
openEHR--OBSERVATION.v0.2
openEHR-EHR-EVALUATION.2steps.v1
openEHR-EHR-EVALUATION.diagnosis
openEHR-EHR-EVALUATION.diagnosis.1
openEHR-EHR-EVALUATION.diagnosis.v
openEHR-EHR-EVALUATION.diagnosis.v00
openEHR-EHR-EVALUATION.diagnosis.v0.00.00
at0.12345
at0.12.345
ac0001
at0001.at0001.at0001';
my $regex = qr/^([a-zA-Z]\w+-[a-zA-Z]\w+-[a-zA-Z]\w+\.[a-zA-Z]\w+(?:-\w+)?\.v\d+(?:\.\d+\.\d+)?(?:(?:-rc|-alpha)(?:\.\d+)?)?)|(at\d{1,4}(?:\.\d{1,4})?)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}