$re = '/^(?:[\s\S]*?\b[45]\d to (?:Str|Int|Dex)){2}/m';
$str = '+51 to Strength
+47 to Intelligence
+79 to maximum Life
+73 to maximum Mana
28% increased Rarity of Items found
+37% to Cold Resistance';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);