$re = '/^[A-Z]+(?:[1-9][0-9]*)?$/m';
$str = 'AAAA
AAA1
AA20
AAA0
AA02
AA3209';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);