const regex = /("ControlLabel": ")(.*)(",\n\s*)("ControlOptions":.*)(Select all that apply:\\r\\n)(.*)(\n\s*"ControlType": ")(OneResponse")/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('("ControlLabel": ")(.*)(",\\n\\s*)("ControlOptions":.*)(Select all that apply:\\\\r\\\\n)(.*)(\\n\\s*"ControlType": ")(OneResponse")', 'gm')
const str = ` }, {
"ControlLabel": "How the post-op instructions were given",
"ControlOptions": "Select all that apply:\\r\\ncomputer generated\\r\\nverbal\\r\\nwritten",
"ControlType": "OneResponse",
"Descript": "Post-Op Instructions"
}, {
"ControlLabel": "The degree of scaling",
"ControlOptions": "general\\r\\nlight",
"ControlType": "MultiResponse",
"Descript": "Prophy Scaling"
}, {
"ControlLabel": "The quadrants",
"ControlOptions": "Select all that apply:\\r\\nUpper Right\\r\\nUpper Left\\r\\nLower Right\\r\\nLower Left",
"ControlType": "OneResponse",
"Descript": "Quadrant-Select Multiple"`;
const subst = `\1\2. Select all that apply.\3\4\6\7MultiResponse"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);