const regex = /(?=.*\d)^(Rp|Rp )?(([1-9]\d{0,2}((\.\d{3})*|\d+))|(0+[1-9]+(\d+|(\.\d{3})*)))(,\d{1,2})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=.*\\d)^(Rp|Rp )?(([1-9]\\d{0,2}((\\.\\d{3})*|\\d+))|(0+[1-9]+(\\d+|(\\.\\d{3})*)))(,\\d{1,2})?$', 'gm')
const str = `18.215
Rp17500
Rp17.500,00
Rp 120.325
005.000.000.100
001100
10
20000000
100000000
100000001
1000
3000 Rp
Rp
0.999
-1,000
-10
1.1000
17,500
2 500
005.1a2
ram123.12213
ramdan890.9090909`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}