import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=<img)([^>]*)([0-9]+.imgdomain\\.com)[^>]*?>";
final String string = "<div class=\"separator\" style=\"clear: both; text-align: center;\">\n"
+ "<img src=\"/demodomain.com/-13ucJuEQEUw/linktoimg.png\"><a href=\"https://12.imgdomain.com/-13ucJuEQEUw/linktoimg.png\" imageanchor=\"1\" style=\"margin-left: 1em; margin-right: 1em;\"><img border=\"0\" data-original-height=\"618\" data-original-width=\"1062\" height=\"372\" src=\"https://21.imgdomain.com/-13ucJuEQEUw/WsGsjY2E2bI/-13ucJuEQEUw/linktoimg.jpg\" width=\"640\"></a></div>\n\n"
+ "<div class=\"separator\" style=\"clear: both; text-align: center;\"><img src=\"/demodomain.com/-13ucJuEQEUw/linktoimg.png\"><a href=\"https://12.imgdomain.com/-13ucJuEQEUw/linktoimg.png\" imageanchor=\"1\" style=\"margin-left: 1em; margin-right: 1em;\"><img border=\"0\" data-original-height=\"618\" data-original-width=\"1062\" height=\"372\" src=\"https://21.imgdomain.com/-13ucJuEQEUw/WsGsjY2E2bI/-13ucJuEQEUw/linktoimg.jpg\" width=\"640\"></a></div>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}