#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(?=.*[a-zñ])(?=.*[A-ZÑ])(?=.*[áéíóúÁÉIÓÚ])(?=(?:\D*\d){3}\D+$)(?=.*[$€*])[a-zA-Záéíó úÁÉÍÓÚñÑ$€*\d]{8,16}$"
Local $sString = "C0mpl1c4dí$imo"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")