$re = '/(?m)^\-{4}[\r\n]([\s\S]+?(?=^\-{4}[\r\n]))^\-{4}[\r\n]/m';
$str = '
----
----
----
fff
----
----
df123 dsfds
ggdg fsdf
----
----
dfdsfds
gfsdf
----
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);