import Foundation
let pattern = #"\"\[{"area":""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"[{lat: "[{"area":"-22.88975203013098", lng: "-43.12695211119432,"},…] 0 : {lat: "[{"area":"-22.88975203013098", lng: "-43.12695211119432,"} 1 : {lat: "-22.88977179811704", lng: "-43.12685018725176,"} 2 : {lat: "-22.88979650809557", lng: "-43.126624881694504,"} 3 : {lat: "-22.890513095516", lng: "-43.12649077124376,"} 4 : {lat: "-22.89054274732773", lng: "-43.126807271907516,"} 5 : {lat: "-22.88975203013098", lng: "-43.12695211119432"}]"}"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)