package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:[^0-9.-]|\.{2,}|-{2,})+`)
var str = `abc--test
a.bc
a-bc
123
45-65`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}