$re = '/(?<!\d)(?=\d+)/m';
$str = 'Mr. Smith12 Some street
Mr. Jones345 Another street
Mr. Anderson6 A different street
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);