using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+(?=,[^,]*$)|^\d+$";
string input = @"0, 2, 3
1, 3, 6, 8
8, 4
9, 3, 5, 3, 7
8";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}