import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)^[a-f\\d]{2}([.:-]?)([a-f\\d]{2}\\1){4}[a-f\\d]{2}$";
final String string = "01:02:03:04:ab:cd\n"
+ "definitely:not:a:mac\n"
+ "01-02-03-04-ab-cd\n"
+ "01.23.45.67.89.ab\n"
+ "0123456789ab\n"
+ "0000000:::::00000\n"
+ "0123456789abcdef:";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}