package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[0-9]{3} ?[0-9]{2}`)
var str = `102 00 12000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}