using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b([A-ZĄĆĘŁŃÓŚŹŻ]+[a-ząćęłńóśźż]*)(cz)([a-ząćęłńóśźż]*[^a\s\t])\b";
string input = @"Podrecznik Podręczniki Podraęcznika Podręcznikówę Podręcznikowi Podręcznikom
Podręcznik Podręczniki Podręcznikiem Podręcznikami Podręczniku
Podręcznikach Podręczniku Podręczniki
Paczka
Paczki Paczki Paczek Paczce Paczkom Paczkę Paczki Paczką Paczkami Paczce
Paczkach Paczko Paczki
Wisząc Zaszyć Żłobiąc Żółw chociaż
kończy
początek
podręcznik
paczka
Paczka
żaczek
żaczka
Żaczka";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}