package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-zA-Z]+(\d+))`)
var str = `I want to capture only the number in words like test123 that ends with a number`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}