$re = '/(?:[a-zA-Z]+(\d+))/m';
$str = 'I want to capture only the number in words like test123 that ends with a number';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);