re = /^([a-zA-Z0-9._+-]+)(@[a-zA-Z0-9-]+)(.[a-zA-Z]{2,4}){2,}$/m
str = 'myname@google.co.in
myname@..in
myname@domain..in
........@........az.az'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end