re = /(?'type'A|B|C)-(?:(?'diameter'\d+)x)?(?'length'\d+)?/m
str = 'A-5
B-6x3
C-79
A-99x1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end