use strict;
my $str = '1652855102: New connection from xx.xx.xx.xx on port xxxx.
1652855102: Socket error on client <unknown>, disconnecting.
1652855102: Received PUBLISH from 16838547124974742985 (d0, q1, r0, m235, \'s/uc/mpd/16838547124974742985\', ... (30 bytes))
1652855102: Sending PUBACK to 16838547124974742985 (m235, rc0)
1652855102: Sending PUBLISH to mqtt_7811e829.e2e5e8 (d0, q1, r0, m42277, \'s/uc/mpd/16838547124974742985\', ... (30 bytes))
1652855102: Sending PUBLISH to dad3d73-013c-4274-a782-cdd6f2ebbc77 (d0, q0, r0, m0, \'s/uc/mpd/16838547124974742985\', ... (30 bytes))
1652855102: Received PUBACK from mqtt_7811e829.e2e5e8 (Mid: 42277, RC:0)
1652855103: Received DISCONNECT from 16838547082470259932
1652855103: Client 16838547082470259932 disconnected.';
my $regex = qr/(?m)^(\d{10}):\s+(.+)/mp;
my $subst = '$1|$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";