$re = '/(\:(.*?\(?\)))|(\:(.*))/';
$str = '
a[href="#"]{
color: red;
}
a[href="#"],div{
color: red;
}
a::hover{
}
a:ntd-child(2n){
}
a:first-letter{
display:block;
}
a::first-letter{
display:block;
}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);