#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mu)([\'\"])([^\\]|\\.(?#如果有转义字符,必然是成对出现))*?\1(?#匹配和前面相同的引号)"
Local $sString = "SELECT 'a', "b" from table where a = '这是"一句\"断\'了的话' And b <> '特别""的"""结尾\\\'\\' And c in ('单引号', "双引号") and d in ( select 'vv' from table_b ) ORDER BY table.id DESC limit 100,10"
Local $sSubst = "?"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)