$re = '/^(?!backend-1).*$/m';
$str = 'backend-1
backend-2
backend-3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);