$re = '/^(\'?)[a-z]\1$/m';
$str = '\'a\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);