# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?#day)(?>(?<day>[0-9]+)(?:(d$)|(d(?=[0-9]))|(:(?=[0-9]+(:|h)[0-9]+(:|m)[0-9]+))))?(?#dayEnd )(?#hour)(?>(?<hour>[0-9]+)(?:(h$)|(h(?=[0-9]))|(:(?=[0-9]+(:|m)[0-9]+))))?(?#hourEnd )(?#min)(?>(?<min>[0-9]+)(?:(m$)|(m(?=[0-9]))|(:(?=[0-9]))))?(?#minEnd )(?#sec)(?>(?<sec>[0-9]+((\.|\,)[0-9]*)?)(?:s|$))?(?#secEnd )(?#msec)(?>(?<msec>[0-9]+)(?:(ms$|$)))?(?#msec)$"
test_str = ("10s55\n"
"10:10s44\n"
"10:10s\n"
"10:15s\n\n"
"10d99h88m77s66ms\n"
"99h88m77.66s\n"
"99h88m77.66\n"
"99:88:77.66\n"
"999999d888888:77,66\n"
"10:99:88:77.66\n"
"99:88:77,66s\n"
"88h55:77\n"
"99h\n"
"88m\n"
"77\n"
"77.5\n"
"77s\n"
"77.66s\n"
"77.66s\n"
"88m\n"
"55ms\n"
"10d55ms\n"
"100m\n"
"3600s\n"
"59:59\n"
"59m59s99ms\n"
"24:59:59.99\n"
"1:24:59m59.123\n"
"59:59.0\n"
"59.0\n"
"1d50ms\n"
"10:123\n\n\n\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.