re = /([\u0024\u0040\u0060]|(?![\u0000-\u00A0])|(?![\u8000-\udfff]))/m
str = 'asdfsdfsfa'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end