#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^#+\s*(.*?)\{#(.*)\}"
Local $sString = "# Scoring import {#calculate-score}" & @CRLF & _
"" & @CRLF & _
"Loads Scoring*csv files from the WebDAV and import them locally." & @CRLF & _
"While processing and when finished, the file gets renamed on the WebDAV." & @CRLF & _
"" & @CRLF & _
"# Response export {#unsubscribe-export}" & @CRLF & _
"" & @CRLF & _
"Exports unsubscribes, bounces and complaints and stores the export files " & @CRLF & _
"on an SFTP of the customer." & @CRLF & _
"" & @CRLF & _
"# Campaign uploader {#15mins-campaign-uploader}" & @CRLF & _
"" & @CRLF & _
"Fetches a ZIP from the customers SFTP. " & @CRLF & _
"This ZIP must contain a JSON and a HTML. Images must be stored in a `img` " & @CRLF & _
"folder. Size limit for an image is 1 MB. Images will be uploaded to the " & @CRLF & _
"Suite media library. Campaign meta data will be read from the JSON." & @CRLF & _
"" & @CRLF & _
"**This process is currently deactivated** " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"# ecard invite a friend landing page {#recommendation-form}" & @CRLF & _
"" & @CRLF & _
"A form to invite friends. The friends data will be stored in the Suite account." & @CRLF & _
"" & @CRLF & _
"# Pretrip form {#pretrip-information-form}" & @CRLF & _
"" & @CRLF & _
"Asking the end user to provide more more data before they arrive." & @CRLF & _
"" & @CRLF & _
"# Signup pages and preference center {#preference-center}" & @CRLF & _
"" & @CRLF & _
"Pages to subscribe and to manage personal data."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")